The analyzer is switched on, but there is no information on display. How I can check the condition of the working of the various modules?

There are several possible reasons if there is no information on the display after the analyzer is switched on:
  1. There is no available power supply(can be checked without opening of the milk analyzer box)

  2. Broken LCD module or no connection with the Main PCB. In this case: please check the cables and the connectors between LCD and Main PCB and adjusting the coupling between them. This procedure is performed with the power off and open box of the device.  

  3. Broken Main PCB module. After you turn on the power at normal condition the Main PCB starts the pump in order to drain any sample residues. Note that this happens (you should here the noise of the running pump). Possible reason for that can be a problem of the Main PCB or peristaltic pump. This can be checked without opening of the milk analyzer box. If this step is successfully completed, further information about the condition of the analyzer is the beep that sounds. If the analyzer beeps it means that the Main PCB works and then you must check the connections with the LCD module.

  4. If there is no any sound, then you must open the analyzer and to turn it on. Check the both LED indicators if some of them lights continuously for more than 2-3 seconds without changing of the light intensity, switch off the analyzer immediately  and send it to the nearest available service center. If the tests are successful and device still doesn’t work the damage is in the LCD module.

 

 

English
English